12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeFAQRegisterLog in

Share | 
 

 Keeps blowing Fuses . GRiSO 8v

View previous topic View next topic Go down 
AuthorMessage
jollyjeweller
Montanarolo
Montanarolo


Posts : 13
Join date : 2013-12-09

PostSubject: Keeps blowing Fuses . GRiSO 8v   Sun Jul 05, 2015 1:27 pm

Chaps.
2010 GRiSO 8v.
The fuse labelled B in the fuse box, 15A Auxiliary that looks after tail light/license plate light/indicators and ignition relay.
Turn the bike on, does all its checks, press the starter, nothing, fuse has gone again.
Must be 6 or 7 gone now.
Any thoughts ?
Neil.
Back to top Go down
Pete Roper
GRiSO
GRiSO


Posts : 3870
Join date : 2013-05-30
Age : 59

PostSubject: Re: Keeps blowing Fuses . GRiSO 8v   Sun Jul 05, 2015 1:42 pm

Clean up the earths and main feeds plus battery terminals and bung in a 20A fuse. It's a current draw problem due to the odd Guzzi starting system.

Pete
Back to top Go down
Josh.C
Grignapoco
Grignapoco


Posts : 127
Join date : 2015-04-17
Age : 34

PostSubject: Re: Keeps blowing Fuses . GRiSO 8v   Mon Jul 06, 2015 2:48 am

Mine has done this for no apparent reason maybe 4-5 times, although I've been putting a 15A back in each time. Happened again last week so I've put in a 20A now. We'll see how this goes.
Back to top Go down
Sponsored content




PostSubject: Re: Keeps blowing Fuses . GRiSO 8v   Today at 9:46 am

Back to top Go down
 
Keeps blowing Fuses . GRiSO 8v
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: