12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeFAQRegisterLog in

Share | 
 

 Guzzi diag and stupid questions

View previous topic View next topic Go down 
AuthorMessage
MrGPz
Tanabuso
Tanabuso


Posts : 89
Join date : 2015-12-19

PostSubject: Guzzi diag and stupid questions   Mon Mar 21, 2016 12:23 am

Hi,
I have read a lot of the posts about Guzzidiag etc and have gone and bought the cables etc.
Good news is that, following Beetles directions, i have connected to and downloaded/uploaded the .bin file etc using Guzzidiag.
It all works great.
I have the cables from Lonelec
Win10 Laptop
Everything worked first time without any issues
I have modified the speedo correction, using Tunerpro, which is great.
I have reset the TPS, each time, after writing to the ECU.

Questions now,
Does the TPS need resetting if it stays at 4.7 after writing to the ECU?
When doing the TPS reset do i need to get the engine temp to a specific temperature, or can it be done cold?
I did reset the TPS and now it stays at 4.6 no matter how many times I reset it (was 4.7 originally).
When would you reset the auto-learning parameters?
Can someone point me in the direction of the posts involving turning off the Lambda sensor and why?

I'm not keen to modify the tuning parameters myself, I'll buy one of Beetles maps if I decide to go that way.
The standard map is very flexible around town, might not be as strong as it could be on the open road.
Back to top Go down
beetle
GRiSO
GRiSO


Posts : 3959
Join date : 2013-09-30

PostSubject: Re: Guzzi diag and stupid questions   Mon Mar 21, 2016 1:33 am

I always reset the TPS after reflashing. It doesn't always change, but if you make any major changes, the value can change by a few degrees either way. This has been my experience. I recommend you do a TPS reset always.

Try opening the throttle to about 50% and let it close by itself, do not force it. Closing the throttle manually can give you a bad value. Then do your reset.

You only need to reset the auto-learning parameters once; the very first time you load an open loop map (lambda off). Or should you ever load a map with lambda on, reset them again the next time you try an open loop map.

I wrote a howto for TunerPro with an example of how to turn off the lambda: [You must be registered and logged in to see this link.]


Turning off the lambda sensor stops the ECU trimming. You will need to reset the auto-learning parameters after you reflash. Doing this on a stock GRiSO map will only make it run rich everywhere.
Back to top Go down
voulga77
Don Abbondio
Don Abbondio


Posts : 46
Join date : 2014-08-26

PostSubject: Re: Guzzi diag and stupid questions   Mon Mar 21, 2016 4:33 am

Perhaps my Guzzidiag version is old but I have always found more effective to reset the auto-learning parameters by cutting the power to the ECU. I just remove the two 30 A fuses for a couple of hours.

With stock map it made a difference, so I keep doing it that way with Beetlemaps.
Back to top Go down
pauldaytona
Fra Cristoforo
Fra Cristoforo


Posts : 379
Join date : 2014-01-07

PostSubject: Re: Guzzi diag and stupid questions   Mon Mar 21, 2016 2:12 pm

The setting after tps reset depends on the map you have. Guzzi thinks 4.5- 4-8 is good if I remeber out of the shop manual. If you have the same basemap, tps should stay after loading the new map. But it's easy to do it anyway.
If you really want to know, get the eprom reader and read eprom before you do anything, then do what you want and read the eprom again, hex compare the two files. The setting of tpsreset and reset autolearning get written after you turnoff the key. And wait a moment.
Back to top Go down
http://www.fastguzzi.nl
Sponsored content




PostSubject: Re: Guzzi diag and stupid questions   Today at 8:35 pm

Back to top Go down
 
Guzzi diag and stupid questions
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: