12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeFAQRegisterLog in

Share | 
 

 Stelvio is giving me fits...

View previous topic View next topic Go down 
AuthorMessage
Steak
L'Innominato
L'Innominato


Posts : 1905
Join date : 2013-05-28
Age : 51

PostSubject: Stelvio is giving me fits...   Fri Apr 08, 2016 2:14 pm

OK, I'm spinning this off from the Ducati ECU thread.

So I'd been riding the Stelvio all winter without any issue. It then sat for a couple of weeks back in late February. I meant to take it for a ride but it struggled to start and wouldn't hold idle. Since the weather has been nice I've just been riding the GRiSO (happily) but now need to solve this Stelvio problem.

At first I thought it might be a mapping problem, so I've tried four different Stelvio maps without any luck. Checked both spark plugs (nearly new - performed routine service about 800 miles ago) getting spark, but the right side seems to be running rich compared to the left. I've checked and cleaned the ECU terminal connections, AOK. I've checked all battery and earth/ground connections, AOK. Installed a new battery yesterday as the old one seemed to be dropping voltage under load. Checked airbox and filter, getting good flow.

Now I'm a bit stumped as to what to try next. Here's a video of the currently trembling pile of shite...



Something any halfway decent mechanic would know on face value that I'm too inept to recognize? Any suggestions?

--- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
[You must be registered and logged in to see this image.]

2012 MOTO GUZZI GRiSO 1200SE

2013 MOTO GUZZI STELVIO 1200NTX - Orange Blossom Special
Back to top Go down
http://www.grisoghetto.com
Pete Roper
GRiSO
GRiSO


Posts : 3780
Join date : 2013-05-29
Age : 59

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 2:28 pm

Is the TPS moving smoothly?
Back to top Go down
Steak
L'Innominato
L'Innominato


Posts : 1905
Join date : 2013-05-28
Age : 51

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 3:17 pm

Yes, it is...

It also seems to be improving. I'm going to see if I can run the sputters out of it...

--- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
[You must be registered and logged in to see this image.]

2012 MOTO GUZZI GRiSO 1200SE

2013 MOTO GUZZI STELVIO 1200NTX - Orange Blossom Special
Back to top Go down
http://www.grisoghetto.com
Pedro
Fra Cristoforo
Fra Cristoforo


Posts : 2
Join date : 2015-03-19

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 3:18 pm

I had the sputters run out of me once. Vast improvement.
Back to top Go down
beetle
GRiSO
GRiSO


Posts : 3970
Join date : 2013-09-30

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 3:22 pm

Phase sensor?
Back to top Go down
Yodasoldier
Carlotto
Carlotto


Posts : 45
Join date : 2016-02-09

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 4:00 pm

That seems like my GRiSO with its water logged TPS.. Are the readings fine from the TPS in Guzzidiag?
Does it idle ok...but throttle makes it sick?
Back to top Go down
Steak
L'Innominato
L'Innominato


Posts : 1905
Join date : 2013-05-28
Age : 51

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 4:19 pm

Well there it is. Just needed to put the boots to her for a spell and run it out of her! Back to running like a top now.

And I got to try out a new camera mount. Fresh test video to follow.

[You must be registered and logged in to see this image.]

[You must be registered and logged in to see this image.]

--- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
[You must be registered and logged in to see this image.]

2012 MOTO GUZZI GRiSO 1200SE

2013 MOTO GUZZI STELVIO 1200NTX - Orange Blossom Special
Back to top Go down
http://www.grisoghetto.com
Pete Roper
GRiSO
GRiSO


Posts : 3780
Join date : 2013-05-29
Age : 59

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 4:32 pm

Weird? Perhaps you got a bung load of fuel? How long was it sitting? Ethenol fuels go off in next to no time, yet another reason they are shite!

Pete
Back to top Go down
Steak
L'Innominato
L'Innominato


Posts : 1905
Join date : 2013-05-28
Age : 51

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 4:34 pm

That could have been it. That and giving the new fuel filter and line time enough to settle in.

Still, all is groovy.

afro Viva la Fiesta

--- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
[You must be registered and logged in to see this image.]

2012 MOTO GUZZI GRiSO 1200SE

2013 MOTO GUZZI STELVIO 1200NTX - Orange Blossom Special
Back to top Go down
http://www.grisoghetto.com
Grisonut
GRiSO
GRiSO


Posts : 1015
Join date : 2014-01-02

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 8:32 pm

Yeah Baby, yeah!!
Back to top Go down
LBC Tenni
Nibbio
Nibbio


Posts : 502
Join date : 2014-06-05

PostSubject: Re: Stelvio is giving me fits...   Fri Apr 08, 2016 10:54 pm

Blame ethanol. Works for me. Makes me feel better, whether it's true or not. F*ing pisswasser!
Back to top Go down
GHTE
Tanabuso
Tanabuso


Posts : 75
Join date : 2015-02-09
Age : 63

PostSubject: Re: Stelvio is giving me fits...   Sat Apr 09, 2016 1:25 am

Love that Stelvio colour Steak
Back to top Go down
pauldaytona
Fra Cristoforo
Fra Cristoforo


Posts : 383
Join date : 2014-01-07

PostSubject: Re: Stelvio is giving me fits...   Sat Apr 09, 2016 1:33 am

that camera mount is pulling vacuum? Because the tank cap has a small vent to the outside.
Back to top Go down
http://www.fastguzzi.nl
Steak
L'Innominato
L'Innominato


Posts : 1905
Join date : 2013-05-28
Age : 51

PostSubject: Re: Stelvio is giving me fits...   Sat Apr 09, 2016 11:04 am

I don't think so Paul, it doesn't seal at all.  It's just a plate mounted to a GIVI Tanklock receiver.

If you were thinking that may have contributed to the fueling fits, I hadn't used the camera mount until after I got the fueling back under control.  I only finished building the mount yesterday. It's a little noisy/rattle-ly though. I'm going to have to dampen it a bit with some rubber grommets or somesuch.

--- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
[You must be registered and logged in to see this image.]

2012 MOTO GUZZI GRiSO 1200SE

2013 MOTO GUZZI STELVIO 1200NTX - Orange Blossom Special
Back to top Go down
http://www.grisoghetto.com
Sponsored content




PostSubject: Re: Stelvio is giving me fits...   Today at 12:14 pm

Back to top Go down
 
Stelvio is giving me fits...
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: