12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeFAQRegisterLog in
Share
 

 ECU disconnect on 2006 GRiSO 850

Go down 
Go to page : Previous  1, 2
AuthorMessage
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper

Posts : 6309
Join date : 2013-05-30
Age : 62

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Mon Apr 09, 2018 8:26 pm

No switch. It’s just about the simplest motorbike in the world. Take it to a decent mechanic.
Back to top Go down
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Tue Apr 10, 2018 7:23 pm

Got it going an hour ago,said have 1 more go at it before arranging mechanic tomorrow.Turn on ignition,usual ECU thing up,hit few buttons/switches,left rear indicator not working and bulb up on dash as well as ECU thing,removed rear section,found orange wire & connector gone green & moldy,wasnt indicator though,wire fell out off connector,could see no 2nd wire or anywhere it could be going.Made a U wire and stuck it in,turned on ignition n neutral n sidestand lights stayed on and that ECU disconnect gone,bike fired and started so thanks all anyway.
Back to top Go down
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper

Posts : 6309
Join date : 2013-05-30
Age : 62

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Tue Apr 10, 2018 8:25 pm

I can’t see anything in the tail section having an effect on the ECU but good it’s fixed.
Back to top Go down
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Tue Apr 10, 2018 9:40 pm

Definitely that anyway,disconnected it few times and ECU disconnect up,reconnect and start perfect.It on right hand side under that plastic cover held on by 2 size eleven bolts.
Back to top Go down
GR1064
GRiSO Capo
GRiSO Capo
GR1064

Posts : 37
Join date : 2014-04-17
Age : 62

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Tue Apr 10, 2018 10:39 pm

John Mar wrote:
Got it going an hour ago,said have 1 more go at it before arranging mechanic tomorrow.Turn on ignition,usual ECU thing up,hit few buttons/switches,left rear indicator not working and bulb up on dash as well as ECU thing,removed rear section,found orange wire & connector gone green & moldy,wasnt indicator though,wire fell out off connector,could see no 2nd wire or anywhere it could be going.Made a U wire and stuck it in,turned on ignition n neutral n sidestand lights stayed on and that ECU disconnect gone,bike fired and started so thanks all anyway.


I’ve found a connector with a loop of wire attached in my G1100 tail section.  It’s not present in the G1200 (according to the G1200 circuit diagram).

I think the G1100 wiring is likely similar to the G850, if so that wire loop connects 12V to the ECU.

Brian

[You must be registered and logged in to see this image.]
Back to top Go down
beetle
GRiSO Capo
GRiSO Capo
beetle

Posts : 6566
Join date : 2013-09-30

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Tue Apr 10, 2018 11:11 pm

That's for the diode they use to use (I believe) in older pre-5AM bikes, to prevent the ECU from meltdown should the battery be connected arse about.



Back to top Go down
https://www.griso.org
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Tue Apr 10, 2018 11:41 pm

Yes thats it exactly.
Back to top Go down
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Fri Apr 13, 2018 9:16 pm

Spoke too soon,went for spin bout 6,7 miles after getting it going,speedo not working and SERVICE up on dash where ECU thing was,otherwise was going good.Got home left it few hours when noticed grips were hot,hot grips left on,didnt realise were set on it,anyway battery seemed flat.Charged it,tried it today,no go,red triangle on at top right of clocks,SERVICE on and 3rd,bigger relay under right hand side panel by seat clicking once or twice.
Back to top Go down
kiwi dave
Tiradritto
Tiradritto
kiwi dave

Posts : 327
Join date : 2014-04-24
Age : 71

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Fri Apr 13, 2018 10:47 pm

First thing I would do is replace the battery. Then start troubleshooting.
Back to top Go down
http://www.guzzigander.com
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Fri Apr 13, 2018 11:28 pm

Thought of battery alright but according to markings its only year old,when hit start button,relay seems click twice.
Back to top Go down
Oz1200Guzzi
Don Abbondio
Don Abbondio
Oz1200Guzzi

Posts : 3623
Join date : 2014-03-13
Age : 64

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 12:43 am

Since you have already experienced dodgy connections, I would further explore that option.

However it would seems you do have a dicky battery. You might want to do the "startus interruptus" mod while you are in there - it's not hard.

Check your earths - main earth is under the spacer that mounts the cover over the starter motor - this is a really crappy spot. Many of us have moved the main earth to one of the clutch housing bolts directly above.
Back to top Go down
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 2:24 pm

Took the cover off the starter,all is clean,no corrosion at all,is a black wire with female connector there stray alright,but cant see any other round there to connect it with.Seen someone else with similar problem on another site say putting bike in gear and rocking it forward often solves it,tried it and just knocked lights off dash,now none except sidestand,put in a good,charged battery also,no difference.Not trying to offend anyone here except moto guzzi of course but these bikes seem to be a major pile of shite.
Back to top Go down
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper

Posts : 6309
Join date : 2013-05-30
Age : 62

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 3:14 pm

Yup, that’s why nobody here who actually listens to and acts on advice given has many problems. Do the bike a favour and flog it to someone who cares.
Back to top Go down
motor-timothy
Biondino
Biondino
motor-timothy

Posts : 295
Join date : 2016-12-20

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 3:54 pm

John Mar wrote:
Not trying to offend anyone here except moto guzzi of course but these bikes seem to be a major pile of shite.

One man's best motorcycle ever is another man's worst. Italian electronics do have a reputation of not being incredibly reliable. I had intermittent start issues as well, which I had to solve (after trying several other potential fixes first) by splicing a new wire from the start relay & maintenance relay to the starter solenoid (suggested of course by the folks on this forum). It's very rewarding when you finally figure out what is wrong and fix it, and if you follow the advise given on this forum you will eventually fix it, but I can see how that's not everyones cup of tea.

The GRiSO has some known weak spots but I'd never go as far as to call the GRiSO shite. Every single motorcycle type, from BMW GS's to Honda Goldwings have numerous forum topics about how the ECU exploded/how the final drive self destructed/how the swingarm broke after a small bump/etc..etc.. shit happens.
Back to top Go down
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 7:09 pm

I don't like giving up myself either,put the fully charged battery back in there now,no lights on clocks besides sidestand,clicks gone from relay aswel,now nothing,forgot mention crossed solinoid earlier,just a whirring noise,didnt actually turn over the engine.never came across anything like this before.
Back to top Go down
Grisonut
GRiSO
GRiSO
Grisonut

Posts : 1318
Join date : 2014-01-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 7:20 pm

Buy a fucking Honda, geez...
Back to top Go down
motor-timothy
Biondino
Biondino
motor-timothy

Posts : 295
Join date : 2016-12-20

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 9:07 pm

John Mar wrote:
I don't like giving up myself either,put the fully charged battery back in there now,no lights on clocks besides sidestand,clicks gone from relay aswel,now nothing,forgot mention crossed solinoid earlier,just a whirring noise,didnt actually turn over the engine.never came across anything like this before.

As far as I know if your ECU isn't functioning you can activate the starter motor all you like but it won't start the motorcycle as the ECU won't activate the fuel injection nor the coils for the spark.

I'm not really comfortable giving advise since I'm but a GRiSO novice myself, but I'd double check the ECU connector (look for perhaps broken pins), and (as has been mentioned) triple check the ECU's earth connection. Basically follow all the advise given to you by Pete Roper on the first page and report back. If you are not comfortable around a multimeter find someone who is, and let him check it. Faulty earth can cause all sorts of weird electric issues. Maybe its something else, but at least you can rule it out then.

It won't fix itself though and at this point just changing/reconnecting/charging the battery clearly won't help.
Back to top Go down
avgpetro
Grignapoco
Grignapoco
avgpetro

Posts : 125
Join date : 2016-11-26
Age : 51

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sat Apr 14, 2018 10:09 pm

John Mar wrote:
........
is a black wire with female connector there stray alright,but cant see any other round there to connect it with.
..........
Well, this is a clear sign that something is wrong with the wiring. "female connector" and "round to connect" does not gives a good understanding of what it is. Is it a cable from the original factory wiring? Is it a cable that was added later by somebody for some reason? A photo would tell much more than one can type...

You mentioned earlier something about heated grips. GRiSO does not have those, the factory does not intall any, neither it prepares any wiring to install it later.
So, somebody has done something to the bikes wiring, at least to install the grips.
Who worked on the wiring? Why? Only for the grips or are there any other modifications? What exactly was done?

John Mar wrote:
........ these bikes seem to be a major pile of shite.
This bike, allows the owner to mess with it himshelf for free, instead of having to pay another ape to mess with the bike. ( [You must be registered and logged in to see this link.] )
Its not fair to blaim the bike for the mess done by apes.
Back to top Go down
John Mar
Montanarolo
Montanarolo
John Mar

Posts : 17
Join date : 2018-04-02

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sun Apr 15, 2018 2:22 pm

Its from the wiring loom,above the starter,only mods are the heated grips which were on when I got it,according to the service history they were fitted by a bike shop in Enniskillen,Moto Tempo.Bike was running perfect until parked for 3 weeks waiting for new brake discs,nobody messed with it.
Back to top Go down
avgpetro
Grignapoco
Grignapoco
avgpetro

Posts : 125
Join date : 2016-11-26
Age : 51

ECU disconnect on 2006 GRiSO 850 - Page 2 Empty
PostSubject: Re: ECU disconnect on 2006 GRiSO 850   ECU disconnect on 2006 GRiSO 850 - Page 2 Icon_minitime1Sun Apr 15, 2018 5:38 pm

Black wire, round connector, from the loom, above the starter... sounds like one of the earth wires.

My 1100 that I believe is exactly the same as the 850, has 3 black earth wires (one of those is the thick one from the battery). All 3 have round connectors and are all bolted on the gearbox housing by the bolt that also doubles as (female threaded) support for the starter cover.


If the loose wire is one of those, it would explain all kind of electrical problems, I can't imagine any way that one (only) of the 3 wires could become loose...


TBW, my bike was made at 2006, since then, very few apes messed with it, as happened with all my previous bikes. I bet some ape messed with yours - not yesterday, but sometime, you cant know when the result of the mess will appear...
The main reason I bought the GRiSO, is to avoid paying other apes to do even bigger mess than I could do myshelf for free...
Back to top Go down
 
ECU disconnect on 2006 GRiSO 850
Back to top 
Page 2 of 2Go to page : Previous  1, 2

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: