GRiSO ghetto
Would you like to react to this message? Create an account in a few clicks or log in to continue.


12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeLatest imagesRegisterLog in

 

 2016 guzzi removed tank, wont start

Go down 
3 posters
AuthorMessage
Vintageace
Squinternotto
Squinternotto
Vintageace


Posts : 2
Join date : 2022-12-11

2016 guzzi removed tank, wont start Empty
PostSubject: 2016 guzzi removed tank, wont start   2016 guzzi removed tank, wont start Icon_minitime1Sun Dec 18, 2022 4:02 pm

Hi guts, I removed my tank on 2016 GRiSO, reattached everything, but its not getting any gas,  any ideas,  no smell of gas in exhaust after 5 trys
Back to top Go down
lcjohnny
GRiSO Capo
GRiSO Capo
lcjohnny


Posts : 1273
Join date : 2016-01-25
Age : 67

2016 guzzi removed tank, wont start Empty
PostSubject: Re: 2016 guzzi removed tank, wont start   2016 guzzi removed tank, wont start Icon_minitime1Sun Dec 18, 2022 5:01 pm

Vintageace wrote:
Hi guts, I removed my tank on 2016 GRiSO, reattached everything, .....
Does 'everything' include (1) making sure that the 3 or 4 wire electrical connector to the fuel pump is fully (!) pushed home? (2) being sure that the (awful) fuel connector to the tank is fully engaged (3) kill switch is set to on


just asking....

Bill Hagan and kindoy2 like this post

Back to top Go down
GuzziSteve
Fra Cristoforo
Fra Cristoforo
GuzziSteve


Posts : 591
Join date : 2016-04-14

2016 guzzi removed tank, wont start Empty
PostSubject: Re: 2016 guzzi removed tank, wont start   2016 guzzi removed tank, wont start Icon_minitime1Sun Dec 18, 2022 7:04 pm

Must have got him going, never came back!! Noticed it was his 1st post. Been riding them hills of CA.

Bill Hagan and lcjohnny like this post

Back to top Go down
Vintageace
Squinternotto
Squinternotto
Vintageace


Posts : 2
Join date : 2022-12-11

2016 guzzi removed tank, wont start Empty
PostSubject: Re: 2016 guzzi removed tank, wont start   2016 guzzi removed tank, wont start Icon_minitime1Mon Dec 19, 2022 3:56 am

Thx guys, I pulled the connector apart inspected it, looked new. sprayed it with contact cleaner and it fired right up. weird. I thought perhaps there was some priming issue. this bike only has 2450 miles on it. I put some taller bars on it it fits me much better now. I have some early 850 eldos. I really like them. Im liking this one too. Hits very hard under power. I am looking forward to building a mid pipe, and a muffler, loading a beetle map. Thx Ken

lcjohnny and Svartipants like this post

Back to top Go down
Sponsored content





2016 guzzi removed tank, wont start Empty
PostSubject: Re: 2016 guzzi removed tank, wont start   2016 guzzi removed tank, wont start Icon_minitime1

Back to top Go down
 
2016 guzzi removed tank, wont start
Back to top 
Page 1 of 1
 Similar topics
-
» GRiSO wont start after a ride?
» washed my bike, now it wont start
» GRiSO suddenly wont start (will try, stumbles, but dies)
» Tank rust on a 2016 SE
» Moto guzzi GRiSO 1100 non start

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: