12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeRegisterLog in
Share
 

 Won’t start when cold but randomly

Go down 
AuthorMessage
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Sat Aug 17, 2019 3:15 pm

GRiSO has some problem at cold start but randomly. Some days it starts but some days not.

When pushing on the start button the starter motor tries to start the engine but it doesn’t fire up.

I though it was a Startus Interuptus issue but when I connect a wire directly from the battery to starter motor it doesn’t fire up as well.

Battery is new and well prepared.

Checked fuses, spark plugs but found nothing.

Then took Guzzi Diag and reset TPS and autolearning parameters. Could hear the fuel pump relay when activated manually but no sure which noise it should actually make.

Finally displayed the faults menu and I found the following P0351 and P0352 errors. But it appeared only once because after doing a connect / disconnect sequence with Guzzi Diag it disappeared.

When the engine did fire up by chance I activated manually the stepper motor and found nothing.

When the engine has started once and is warm there is no more start problem.

Don’t know if it is the fuelpump, the phase sensor or the injectors ? Could an injector cleaner to be poured in the tank could help ?

Any ideas ?

[You must be registered and logged in to see this image.]
[You must be registered and logged in to see this image.]
Back to top Go down
BowraBoy
GRiSO Capo
GRiSO Capo
BowraBoy

Posts : 13
Join date : 2019-07-28

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Sun Aug 18, 2019 4:01 am

I have had similar problems. I find that when the temp is<15 degrees C, if I have the throttle slightly open and keep it there until the engine catches my cold starting is much easier.
Back to top Go down
BowraBoy
GRiSO Capo
GRiSO Capo
BowraBoy

Posts : 13
Join date : 2019-07-28

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Sun Aug 18, 2019 4:02 am

I have had similar problems. I find that when the temp is<15 degrees C, if I have the throttle slightly open and keep it there until the engine catches my cold starting is much easier.
Back to top Go down
Kiwi_Roy
Biondino
Biondino
Kiwi_Roy

Posts : 293
Join date : 2017-11-09

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Sun Aug 18, 2019 4:02 am

Quote "When pushing on the start button the starter motor tries to start the engine but it doesn’t fire up"

Are you saying the motor always turns over strongly just doesn't catch?
Back to top Go down
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Sun Aug 18, 2019 1:57 pm

@bowraboy. I’ll try this to help.

@kiwi_roy: Yes it is.

Any ideas with P0351 and P0352 Errors ? It appears that it might be serious if the ECU is involved and no so easy to check the problem.

[You must be registered and logged in to see this link.]
Back to top Go down
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Mon Aug 19, 2019 3:41 pm

Today removed the side covers in order to check if all connections were ok. Found one loose connector on the right side. Fixed it. Then sprayed on all plugs a cleaning for connectors.

Hope this solved the problem.

To be continued …


Last edited by Richard on Thu Aug 22, 2019 10:20 am; edited 1 time in total
Back to top Go down
kiwi dave
Tiradritto
Tiradritto
kiwi dave

Posts : 358
Join date : 2014-04-23
Age : 72

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Tue Aug 20, 2019 3:48 pm

Richard wrote:

Any ideas with P0351 and P0352 Errors ? It appears that it might be serious if the ECU is involved and no so easy to check the

I'm confused that Guzzidiag is reporting these errors, as they are for the IAW 7SM ECU, but obviously you have the 5AM selected.

Hopefully Beetle may leap in and explain what's going on.
Back to top Go down
http://www.guzzigander.com
beetle
GRiSO Capo
GRiSO Capo
beetle

Posts : 6802
Join date : 2013-09-30

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Tue Aug 20, 2019 4:10 pm


Not so. They are regular OBD2 error codes found in the 5AM. Left & right coil errors. Most likely not the ECU as such. A relay/wiring/ground problem more likely. Assuming the battery is OK.



Back to top Go down
https://www.griso.org
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Thu Aug 22, 2019 10:17 am

I think and I hope the problem is solved for good. A loose connector was the culprit. Since I fixed it GRiSO starts like if it was new  bounce
Back to top Go down
kiwi dave
Tiradritto
Tiradritto
kiwi dave

Posts : 358
Join date : 2014-04-23
Age : 72

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Thu Aug 22, 2019 2:20 pm

Richard wrote:
I think and I hope the problem is solved for good. A loose connector was the culprit. Since I fixed it GRiSO starts like if it was new  bounce

Just curious. Which connector?
Back to top Go down
http://www.guzzigander.com
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Thu Aug 22, 2019 3:02 pm

Good question. This is the biggest one on the right side. I can’t say the use of this connector but it separated in two pieces when jiggled a little bit the wires on the right side of the bike.

I’ll take a picture.
Back to top Go down
beetle
GRiSO Capo
GRiSO Capo
beetle

Posts : 6802
Join date : 2013-09-30

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Thu Aug 22, 2019 3:12 pm


The only one that springs to mind is the fuel pump connector.





Back to top Go down
https://www.griso.org
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Thu Aug 22, 2019 3:15 pm

Yes ! You are right. I checked on the spare parts manual and this is certainly the one.
Back to top Go down
kiwi dave
Tiradritto
Tiradritto
kiwi dave

Posts : 358
Join date : 2014-04-23
Age : 72

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Thu Aug 22, 2019 5:37 pm

So much for the OBD2 error codes then.
Back to top Go down
http://www.guzzigander.com
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Sat Aug 24, 2019 7:53 am

Here is the loose connector. Fuel pump confirmed. Problem solved so far.

[You must be registered and logged in to see this image.]
Back to top Go down
Kiwi_Roy
Biondino
Biondino
Kiwi_Roy

Posts : 293
Join date : 2017-11-09

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Tue Oct 01, 2019 11:51 pm

It stands to reason the bike won't start if the fuel pressure is low due to a bad connector.
Good catch Richard.
Back to top Go down
Richard
GRiSO Capo
GRiSO Capo
Richard

Posts : 415
Join date : 2018-10-04
Age : 56

Won’t start when cold but randomly  Empty
PostSubject: Re: Won’t start when cold but randomly    Won’t start when cold but randomly  Icon_minitime1Wed Oct 02, 2019 2:06 pm

And no more cold start difficulties since I fixed this loose connector Wink
Back to top Go down
 
Won’t start when cold but randomly
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: