12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeRegisterLog in
Share
 

 Stuttering engine

Go down 
AuthorMessage
josv
Montanarolo
Montanarolo
josv

Posts : 12
Join date : 2014-11-29
Age : 62

Stuttering engine Empty
PostSubject: Stuttering engine   Stuttering engine Icon_minitime1Sun Sep 15, 2019 9:33 am

Hello again, after rollerising the engine, 4000 km. ago, it was running fine untill last week, now i notice that when im driving at 3000-4000 rpm. and i open the throttle, it hesitates under acceleration for a short moment, for instance making a bent and open throttle again, it looks like a ignition failure, it does not acclerate all the way, but it stuters a few times, i noticed a cable was not sticking right on the ignition relais, so i fixed that also whit a new relais, i put in new sparks, it has the new NGK caps, i checked the wiring on the ignition coils, it all seems all right, its running 1200 rpm. at idle, with the diagnos i cant see any failure, could it be the crankcase sensor failing when it runs at higher speed? Also When i am driving on a bad road, it looks worse. Greetings Jos
Back to top Go down
Kiwi_Roy
Biondino
Biondino
Kiwi_Roy

Posts : 293
Join date : 2017-11-09

Stuttering engine Empty
PostSubject: Re: Stuttering engine   Stuttering engine Icon_minitime1Sun Sep 22, 2019 2:44 am

The first thing I would try is the Side-Stand switch (33)
Perhaps salt water has corroded it
On a rough road it might be bouncing open
[You must be registered and logged in to see this link.]

Unplug the switch and jumper it out to test.
Back to top Go down
josv
Montanarolo
Montanarolo
josv

Posts : 12
Join date : 2014-11-29
Age : 62

Stuttering engine Empty
PostSubject: Re: Stuttering engine   Stuttering engine Icon_minitime1Wed Oct 09, 2019 2:26 pm

Hello again, after checking the side stand, changing the crankshaft RPM sensor, it still stutters and seemingly got worse. i finally bought the beetle map, put it in this evening and surprisingly the problem is solved.it runs in idling better and feels good again, only thing is that the original map was from rexxer tuning ?, and opening the trottle from 2000 rpm in sixth gear was smoother in the rexxer map than in the beetle map. but who cares you usually dont go so low in revs.
Back to top Go down
Oz1200Guzzi
Don Abbondio
Don Abbondio
Oz1200Guzzi

Posts : 3758
Join date : 2014-03-13
Age : 64

Stuttering engine Empty
PostSubject: Re: Stuttering engine   Stuttering engine Icon_minitime1Wed Oct 09, 2019 2:51 pm

Might have been a corrupt map from Rexxer?

Jos, Whatever, it might benefit from a throttle body balance and TPS reset, along with the new map.
Back to top Go down
josv
Montanarolo
Montanarolo
josv

Posts : 12
Join date : 2014-11-29
Age : 62

Stuttering engine Empty
PostSubject: Re: Stuttering engine   Stuttering engine Icon_minitime1Yesterday at 12:23 pm

Hello there, I thought the problem was solved, eventually it is, but the main corse was a cable from the relais that is in the back of the bike, underneath the lock of the saddle.. this relais feeds the ECU and the cable coming from the fuse to this relais was visually without problems but in the inside it was broken !!, with this cable i have driven about 1500 km. with stuttering and it is almost unbelieveable that it did not break at all. eventually it broke complete and the engine did not run at all anymore. failure on the dashbord etc. Then i started measurements from the electrical circuit with use of the schedule, and within an hour i discovered the problem., so a tiny problem at the end, but great results. Greetings Jos
Back to top Go down
Street
GRiSO Capo
GRiSO Capo
Street

Posts : 2087
Join date : 2013-05-29
Age : 60

Stuttering engine Empty
PostSubject: Re: Stuttering engine   Stuttering engine Icon_minitime1Yesterday at 5:57 pm

Way to go, Jos!
Back to top Go down
https://WWW.REIQUAM.COM
 
Stuttering engine
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: