GRiSO ghetto
Would you like to react to this message? Create an account in a few clicks or log in to continue.


12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeRegisterLog in

 

 8v GRiSO - Only firing on one cylinder

Go down 
4 posters
AuthorMessage
Duquois
Carlotto
Carlotto
Duquois


Posts : 32
Join date : 2014-01-24

8v GRiSO - Only firing on one cylinder Empty
PostSubject: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Tue Jan 03, 2023 2:18 pm

Hi Folks,
About 6 weeks ago my 2008 8v GRiSO started misfiring on the left pot at low revs under load. Once speed was up to 40mph plus, it was fine. If I feathered the throttle and gently picked up speed, it was okay.
This steadily became worse though.
I checked the coils (with a coil from another one of my Guzzis) , changed the plugs, caps & leads (both sides), no change.
It then stopped firing on the left pot altogether.
I've checked all the electrical connectors around the engine that I can see and the earths, cleaning & protecting them as I've gone along.
I've removed the engine support bolts and cleaned them.
I've checked the wiring in general and can't find any that are chafed or damaged.
I've also checked the fuel pipes to both injectors, the left was a bit crimped, but I've rerouted it a little. The injectors are working fine.
I haven't done a compression test yet.
I'm becoming a bit stuck and would appreciate any advice you could offer please? Thanks
I did pull one of the lower rubber hoses of the air box and it seemed to be full of the light brown gunk you find on the underside of the rocker cover when changing the oil, but I couldn't see why this might cause a misfire?
I've checked the valve clearances and they seem fine. I installed one of Beetle's maps years ago and it's run great since. It's been rollerised.
It's done over 86k miles (approaching 138k km).
Cheers
Andrew
Back to top Go down
lcjohnny
GRiSO Capo
GRiSO Capo
lcjohnny


Posts : 1438
Join date : 2016-01-25
Age : 68

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Tue Jan 03, 2023 4:11 pm

In the old days ...
Failing spark under load indicated an HT problem

Have you swapped the plug-caps and leads from left to right?
Back to top Go down
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper


Posts : 10293
Join date : 2013-05-29
Age : 67

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Tue Jan 03, 2023 5:59 pm

Despite the caps having been replaced this really sounds like dud cap syndrome. Have you had the *New* caps off since installation? If you have how did you remove them?
Back to top Go down
Dean68uk
Carlotto
Carlotto
avatar


Posts : 28
Join date : 2022-02-11

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Tue Jan 03, 2023 8:30 pm

Have you checked the injector spray pattern and fuel pressure to the LH injector?
Check cam timing is still aligned and compression check on both cylinders to compare.
Had a similar issue and mine was the fuel pressure
Back to top Go down
Duquois
Carlotto
Carlotto
Duquois


Posts : 32
Join date : 2014-01-24

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Sat Apr 29, 2023 3:40 am

Hi folks,
the problem eventually turned out to be the ECU.
I've put a second hand one in and, hey presto, fired up!
Cheers
Andrew

lcjohnny and SemperVee1 like this post

Back to top Go down
lcjohnny
GRiSO Capo
GRiSO Capo
lcjohnny


Posts : 1438
Join date : 2016-01-25
Age : 68

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Sat Apr 29, 2023 5:32 pm

Duquois wrote:
Hi folks,
the problem eventually turned out to be the ECU.
I've put a second hand one in and, hey presto, fired up!
Cheers
Andrew
Thanks for posting the resolution Andrew.

My ECU failed on right side igniton last year (2008/9 model so 14 years after production). There was a lot of oxidation crust between the ECU and heatsink which is not helpful so i cleaned that and appled thermal paste.

Lucky that Ducati have such unreliable engines that the correct GRiSO ecu is widely available Very Happy

Duquois likes this post

Back to top Go down
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper


Posts : 10293
Join date : 2013-05-29
Age : 67

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Sat Apr 29, 2023 5:53 pm

A strange failure. Up until a couple of weeks ago I'd never replaced an ecu due to an *electronic* failure. Physical? Yup, one, maybe two, but never electronic.

Then we got this Sport in from South Australia and it had just blown its second ecu within 10Km of the first. When we looked at it we found the wiring loom had been 'Fixed' by the local Ducati mechanic and was just a nest of fuck-ups. We were going to replace the harness but Michael gritted his teeth and went through it pulling out all the shitty additions and repairing the original and it seems to be OK now.

The W5AM is a stupidly tough unit. With the Sport we think it was voltage flutter from all the weird add ons that fried it. Usually though the ecu is the last place we'd look. I suppose weather and road salt would make things more touchy in the UK.

Duquois and lcjohnny like this post

Back to top Go down
Duquois
Carlotto
Carlotto
Duquois


Posts : 32
Join date : 2014-01-24

8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1Tue May 02, 2023 3:34 am

Hi Pete,
I guess it could be the crappy weather and salt as I use it all year round.
I give it a good coating of ACF50 each October, which helps.
The wiring loom on my bike is standard except for heated grips, which have been on for nearly 10 years.
Cheers
Andrew
Back to top Go down
Sponsored content





8v GRiSO - Only firing on one cylinder Empty
PostSubject: Re: 8v GRiSO - Only firing on one cylinder   8v GRiSO - Only firing on one cylinder Icon_minitime1

Back to top Go down
 
8v GRiSO - Only firing on one cylinder
Back to top 
Page 1 of 1
 Similar topics
-
» GRiSO running on one cylinder?
» GRiSO slave cylinder… rod seized. Mechanic says. SOS.
» GRiSO front master cylinder seep
» GRiSO 8v problem, one cylinder (randomly?) cuts out
» Cylinder pressures - 4v or is it 8v

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: