GRiSO ghetto
Would you like to react to this message? Create an account in a few clicks or log in to continue.


12425 - Established June, 2013 - all GRiSO, all the time...
 
HomeRegisterLog in
 

 Blank MODE Screen

Go down 
+2
Pete Roper
sono
6 posters
AuthorMessage
sono
Carlotto
Carlotto
sono

Posts : 49
Join date : 2015-12-19

Blank MODE Screen Empty
PostSubject: Blank MODE Screen   Blank MODE Screen Icon_minitime1Fri Jul 22, 2016 10:19 am

So everything on my bike was in perfect order and now my MODE screen is blank. Here's what I've done.

1) Remapped my ECU. Steak helped me do it and it's running much better. Didn't go to the MODE screen after, so I'm not sure if it was out or not.

2) Disconnected the battery to install a USB accessory plug. Neg first on removal and last on install.

That's it. I only noticed that the screen was blank when I went to set the clock.

Both TRIP 1/2 screens work as does the main speedo and all lights.

Thoughts or suggestions?
Back to top Go down
http://www.eatonopoke.com
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper

Posts : 8301
Join date : 2013-05-29
Age : 64

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Fri Jul 22, 2016 11:47 am

Is the button on the switchblock working?
Back to top Go down
sono
Carlotto
Carlotto
sono

Posts : 49
Join date : 2015-12-19

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Fri Jul 22, 2016 1:32 pm

Pete Roper wrote:
Is the button on the switchblock working?

You mean the small rubber one to select/reset? Yes... I just zero'd out the .1 miles I rode to see if that would reset the screen.
Back to top Go down
http://www.eatonopoke.com
sono
Carlotto
Carlotto
sono

Posts : 49
Join date : 2015-12-19

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Fri Jul 22, 2016 3:07 pm

Update: disconnected the battery and waited an hour. Reconnected and BAM! Working again.

I happened to be in Greenlake today and stopped by Moto International. Micha suggested the above and it worked. Thank goodness!
Back to top Go down
http://www.eatonopoke.com
Pete Roper
GRiSO Capo
GRiSO Capo
Pete Roper

Posts : 8301
Join date : 2013-05-29
Age : 64

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Fri Jul 22, 2016 4:28 pm

That was going to be my next suggestion. For future reference an added step is to leave the ignition in the 'On' position while the battery is disconnected. There are apparently capacitors of some sort that help store the memory in the dash and if you leave the ignition on they discharge and then when reconnected it boots up from a baseline.

Pete
Back to top Go down
sono
Carlotto
Carlotto
sono

Posts : 49
Join date : 2015-12-19

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Fri Jul 22, 2016 5:42 pm

Another great tidbit for the mental note file... Thanks Pete!
Back to top Go down
http://www.eatonopoke.com
2highlander
Biondino
Biondino
2highlander

Posts : 244
Join date : 2016-09-28
Age : 61

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Tue Jan 31, 2017 1:28 am

Another suggestion is to turn the trip/mode switch to mode before reconnecting the battery. Worked always fine for me.
Back to top Go down
Grisonut
GRiSO
GRiSO
Grisonut

Posts : 1375
Join date : 2014-01-02

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Sun Feb 05, 2017 6:54 pm

Must be a 1100 thing...mine did it once and all I did was to pull over, shut and restart right away and everything came back online.
My departed 09 got stuck at 5mph one time and I used the same procedure...gone after re-start.
Damn Italians!
Back to top Go down
lcjohnny
GRiSO Capo
GRiSO Capo
lcjohnny

Posts : 470
Join date : 2016-01-25
Age : 66

Blank MODE Screen Empty
PostSubject: Blank 'Mode' screen   Blank MODE Screen Icon_minitime1Mon Apr 12, 2021 7:42 am

Just to confirm this thread.
Blank Mode screen also happened to me
So pulled the 2 main 30a fuses for 15 minutes

When I replaced them the Dashboard just went into a reboot.
All settings wiped - but Everything now working again
Back to top Go down
cold hands
Montanarolo
Montanarolo
cold hands

Posts : 14
Join date : 2016-01-07

Blank MODE Screen Empty
PostSubject: Re: Blank MODE Screen   Blank MODE Screen Icon_minitime1Sat Apr 17, 2021 6:28 am

After the first ride of spring I wanted to select mode to check voltage while using a new heated jacket liner but saw a blank screen. Searching old threads quickly led to this one. Now I have a plan to try after it gets warm enough to work outside for a while. For the present I am rather relieved of much worry in case of impending dash failure. Thank you very much.


But what is that picture?
Back to top Go down
 
Blank MODE Screen
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
GRiSO ghetto :: The Ghetto :: GRiSOLOGY-
Jump to: